How to restore Cisco IOS config from backup using console

  1. Install the TeraTerm -> Start and use COM port to connect to console

You console configuration might be as follow

COM1

Speed 9600

Data Bits 8

Stop Bits 1

Parity None

Flow Control None

2. Connect to switch/switch using console

enable

copy xmodem: run (This will copy the config to running config)

Once the transfer is started navigate in Teraterm to

File -> Transfer -> XMODEM -> Send… then select the file.

you can then run

show running-config

and you configuration should be there.

 

 

Cisco vlans/trunks basic configuration examples

/trunk+navive vlan + encapsulation

interface GigabitEthernet0/15
description xx
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 555
switchport trunk native vlan 555
switchport mode trunk
!

//trunk
interface FastEthernet0/9
description yy
switchport trunk allowed vlan 555
switchport mode trunk
spanning-tree portfast
//access
interface FastEthernet0/11
description zz
switchport access vlan 555
switchport mode access
spanning-tree portfast

The most useful Cisco OS commands

X – port number

How to check configuration for specific port

sh run int f0/X  or show running-config interface fastEthernet 0/X

How to check all configuration 

show running-config

How to change description on port

enable

configure terminal

interfaces  fastEthernet 0/X

description MY_NEW_DESCRIPTION

How to set up Trunk( Allow few VLAN’s to access one port)

configure terminal
interface FastEthernet0/X
description MY_NAME

switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan MY_VLAN1,MY_VLAN2

end

How to setup a Native trunk and what is

Windows is not tagging Vlan so you would need to sometimes setup Native VLAN tagging so all the packets which are not tagged will be given this VLAN tag

configure terminal
interface FastEthernet0/X

switchport trunk native My-VLAN

How to save running configuration

enable

copy running-config startup-config