Cisco vlans/trunks basic configuration examples

/trunk+navive vlan + encapsulation

interface GigabitEthernet0/15
description xx
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 555
switchport trunk native vlan 555
switchport mode trunk
!

//trunk
interface FastEthernet0/9
description yy
switchport trunk allowed vlan 555
switchport mode trunk
spanning-tree portfast
//access
interface FastEthernet0/11
description zz
switchport access vlan 555
switchport mode access
spanning-tree portfast

Email Delivery Troubleshooting

To check.

Is SPF records setup correctly? http://mxtoolbox.com/

IS the IP added to the SPF records?

Does the SPF contain hard fail which could prevent email delivery?

Has the server been changed recently e.g. moved to a different provider.

IS MX records setup correctly

 

Images in Emails.

If images are not displaying in Emails then it might means that “wrong SSL” is used or the receiver does not have CA of the sender.

 

How to setup mail relaying in postfix

In postfix

edit the following file

add the below line to /etc/postfix/sender_relay file
@example.com [mail.example.com]

run “sudo postmap /etc/postfix/sender_relay”

reload is not required.

Then check logs in /var/logs . tail -f /var/log/cluster.log | grep –line-buffered “example.com” command might proof useful.

How to cleanup Winsxs folder on Windows 2008 R2 and Windows 7

For many years there was no feature which allowed removing unnecessary files from WinSxS folder. The size only grew to the point where nothing could be removed to free up some space on C: drive.

The below has also been described on Windows Sites but it seems it’s hard to find hence my post below.

  1. First please refer to https://support.microsoft.com/en-us/kb/2852386
  2. You need to download one of the following files which are right for your system.
Operating system Update
All supported x86-based versions of Windows 7 DownloadDownload the update package now.
All supported x64-based versions of Windows 7 DownloadDownload the update package now.
All supported x64-based versions of Windows Server 2008 R2 DownloadDownload the update package now.

3. You need to enable the cleanmgr. This can be done by installing “Desktop Experience” from “Add feature” or by manually enabling cleanmgr.

I have described the manual process under my other post.

https://amionrails.wordpress.com/2016/04/12/how-to-enable-cleanmgr-windows-cleaning-program-on-windows-2008/

Once enabled.

4. Install the hotfix. From my experience, the reboot is not required so it should be fine to install it on the production server. I personally prefer to manually enabling the cleanmgr as you don’t need to install additional software which comes from Desktop Experience e.g. Windows Media Player.

5. Once installed run cleanmgr.

6. Cleanmgr should now discover few GB of old updates which can be removed.

If it does not work any reason or the files are not being removed then you may need to add Windows Desktop Experience Feature and try again.

Windows also mentioned that the reboot is required although it does not require a reboot or force you to do it.