How do I install Gallium3d Drivers in Ubuntu 12.10?

You can find articles and benchmarks of linux display drivers on Phoronix.

If you really want to use gallium3d drivers, open a terminal by pressing CTRL+ALT+T and follow these instructions (taken from here):

  1. Add ppa:oibaf/graphics-drivers Launchpad logo (Click here for instructions on using PPAs.) to your system:

    sudo add-apt-repository ppa:oibaf/graphics-drivers
    sudo apt-get update

  2. Install the driver:

    sudo apt-get install libg3dvl-mesa

  3. Restart.

You can revert to the default drivers by removing the PPA as follows:

  1. Install ppa-purge:

    sudo apt-get install ppa-purge

  2. Purge the PPA:

    sudo ppa-purge ppa:oibaf/graphics-drivers

Mac Os Tranformation Pack for Ubuntu and Linux Mint

http://mbossg.deviantart.com/#/d5jvs5r

===INCLUDE IN PACK===
Mac-X-Lion theme
Mac-X-Lion icons
Mac-Snow-Leopard icons
5 Mac Cursor Themes with script instillation
Mac Wallpapers
And some tweaks to make more look like mac
like how to change home folder icon in unity side bar
and how to change unity side bar ubuntu white logo to apple logo
and how to apply scrollbar like mac

===========================================

important
Make sure both Install Mac OS X Lion Skin Pack.sh & shre folder are in same folder
dont renamed share folder and anything inside the folder.

1: double click on Install Mac OS X Lion Skin Pack.sh script and click on
RUN IN TRMINAL use your password when required
finaly reboot system when installation finished

2: By default it will set Mac-X-Lion theme,Mac-Snow-Leopard icon theme and Mac-Radioactive cursor theme

3: to change Mac-X-Lion icon theme use advanced-system-settinge or ubuntu-tweak to change icon theme
or run this command in terminal (gsettings set org.gnome.desktop.interface icon-theme ‘Mac-X-Lion’)

4: to change different mac cursor theme go to usr/share/icons open mac-cursor-tmeme folder and read the instructions (ther are five different mac-cursors-themes)

5: to remove Mac OS X Lion Skin Pack from system double click on Uninstall Mac OS X Lion Skin Pack.sh script and click on
RUN IN TRMINAL use your password when ask
finaly reboot system when Uninstallation finished

Link Fixed

Download Link
[link]

For Ubuntu 12.4 LTS
[link]

SSD Hosting for 5 dollars a month https://www.digitalocean.com/?refcode=71a52388956e

How To Install AMD Catalyst Legacy Drivers in Ubuntu 12.10/ Linux Mint for better 3d support

Latest proprietary AMD Catalyst driver version 12.9 cannot be used with Ubuntu 12.10 If you have a AMD Radeon HD 2xxx-4xxx series card.

Drivers for these cards are now available in a separate branch called legacy series. Unfortunately these legacy drivers (version 12.6) have not been updated to work with Ubuntu 12.10. Ubuntu 12.10 comes with xorg 1.13 while these drivers have support for older xorg 1.12.
So if you want to install these drivers in Ubuntu 12.10, you have to downgrade to xorg 1.12. A PPA has been provided by Tomasz Makarewicz that includes all the required packages you need to downgrade plus a fglrx-legacy package.
To install these packages, run the following commands:

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Do note that these packages are not officially supported by Ubuntu, so use them at your own risk. If something goes wrong, you can purge the packages by running following commands:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:makson96/fglrx

 

Source: http://www.ubuntuvibes.com/2012/10/how-to-install-amd-catalyst-legacy.html

 

Steam Linux – Games on Linux

Steam is now available on Linux systems – >> HURARRA!!

 

http://steamcommunity.com/linux

It does work.

Steam for Linux is now available in Beta to all users of Steam. With a growing catalog of Linux-supported games and an active Steam for linux community group, the timing’s right to jump in and share your feedback.

cannot load such file — zlib – Ruby RVM or Gem commands

ami@os ~ $ gem install
ERROR:  Loading command: install (LoadError)
cannot load such file — zlib
ERROR:  While executing gem … (NameError)
uninitialized constant Gem::Commands::InstallCommand

You haven’t check the ‘rvm requirements’.

sudo apt-get -y install build-essential openssl libreadline6 libreadline6-dev zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison subversion

Please make sure that you installed all files and then type in this command

 

rvm reinstall 1.9.3

 

This should do the trick. Once reinstalled you should be able to run

gem install rails