Web Testing Tool and Site

HP Load Runner

http://www8.hp.com/us/en/software-solutions/loadrunner-load-testing/try-now.html

WebLoad

Why WebLOAD new design

Searching Multiple file using zgrep

find -name \*.eml.gz -print0 | xargs -0 zgrep "STRING"

You have to escape the first ‘*’ so that the shell does not interpret it. “-print0” tells find to print a null character after each file it finds; “xargs -0” reads from standard input and runs the command after it for each file; “zgrep” works like “grep”, but uncompresses the file first.

Added for myself  for quick info from here:

http://unix.stackexchange.com/questions/187742/how-do-i-grep-recursively-through-gz-files

How to get a free valid SSL

Recently there was no way to get a valid free SSL and you were force to buy one .

Thanks to them you can now get a free SSL which is valid in major browsers.

https://letsencrypt.org/

Some background

The objective of Let’s Encrypt and the ACME protocol is to make it possible to set up an HTTPS server and have it automatically obtain a browser-trusted certificate, without any human intervention. This is accomplished by running a certificate management agent on the web server.

To understand how the technology works, let’s walk through the process of setting up https://example.com/ with a certificate management agent that supports Let’s Encrypt.

There are two steps to this process. First, the agent proves to the CA that the web server controls a domain. Then, the agent can request, renew, and revoke certificates for that domain.

How to clean up Winsxs folder

For Windows 7 Refer to my other blog here:

https://amionrails.wordpress.com/2016/08/05/how-to-cleanup-winsxs-folder-on-windows-2008-r2-and-windows-7/

Windows 2012

Windows 2012 Source: https://technet.microsoft.com/en-gb/library/dn251565.aspx

Deployment Image Servicing and Management (DISM) is a command-line tool that allows you to install, uninstall, configure, and update Windows features, packages, drivers, and international settings. The /Cleanup-Image parameter of Dism.exe provides advanced users more options to further reduce the size of the WinSxS folder. For more information, see DISM Operating System Package Servicing Command-Line Options.

  1. Using the /StartComponentCleanup parameter of Dism.exe on a running version of Windows 8.1 gives you similar results to running theStartComponentCleanup task in Task Scheduler, except previous versions of updated components will be immediately deleted (without a 30 day grace period) and you will not have a 1-hour timeout limitation.From an elevated command prompt, type the following:
    Dism.exe /online /Cleanup-Image /StartComponentCleanup
    
  1. Using the /ResetBase switch with the /StartComponentCleanup parameter of DISM.exe on a running version of Windows 8.1 removes all superseded versions of every component in the component store.From an elevated command prompt, type the following:
    Dism.exe /online /Cleanup-Image /StartComponentCleanup /ResetBase
    
    WarningWarning
    All existing service packs and updates cannot be uninstalled after this command is completed. This will not block the uninstallation of future service packs or updates.
  1. To reduce the amount of space used by a Service Pack, use the /SPSuperseded parameter of Dism.exe on a running version of Windows 8.1 to remove any backup components needed for uninstallation of the service pack. A service pack is a collection of cumulative updates for a particular release of Windows.From an elevated command prompt, type the following:
    Dism.exe /online /Cleanup-Image /SPSuperseded
    
    WarningWarning
    The service pack cannot be uninstalled after this command is completed.

How to force/make a MS SQL Database offline

Sometimes there are active connections preventing a database from making offline.

If you have got SMWS open remotely accessing the DB then this could prevent from making it offline.

You can use the following to make it offline.

This will kill all connections and will close database.

ALTER DATABASE database-name SET OFFLINE WITH ROLLBACK IMMEDIATE

ALTER DATABASE <dbname> SET OFFLINE WITH ROLLBACK IMMEDIATE

o find connections, use sys.sysprocesses

USE master SELECT * FROM sys.sysprocesses WHERE dbid = DB_ID(‘MyDB’)

To force disconnections, use ROLLBACK IMMEDIATE

USE masterALTER DATABASE MyDB SET SINGLE_USER WITH ROLLBACK IMMEDIATE

Cisco vlans/trunks basic configuration examples

/trunk+navive vlan + encapsulation

interface GigabitEthernet0/15
description xx
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 555
switchport trunk native vlan 555
switchport mode trunk
!

//trunk
interface FastEthernet0/9
description yy
switchport trunk allowed vlan 555
switchport mode trunk
spanning-tree portfast
//access
interface FastEthernet0/11
description zz
switchport access vlan 555
switchport mode access
spanning-tree portfast

Email Delivery Troubleshooting

To check.

Is SPF records setup correctly? http://mxtoolbox.com/

IS the IP added to the SPF records?

Does the SPF contain hard fail which could prevent email delivery?

Has the server been changed recently e.g. moved to a different provider.

IS MX records setup correctly

 

Images in Emails.

If images are not displaying in Emails then it might means that “wrong SSL” is used or the receiver does not have CA of the sender.